VM Not working in Windows 10


#1

Hi i’m installing spryker through virtual machine, as per this below link https://academy.spryker.com/getting_started/installation_guide.html.

But i have error comes like this while enter this command - “vagrant up”

so i created project folder and downloaded the spryker with command “git clone https://github.com/spryker/demoshop.git”, like as below screen
mintty_2018-05-31_16-30-30

my self then again run the command - “vagrant up”, then finally i got error like below

please help me.


#2

Hello,

Thank you for using Spryker! There are currently a couple of issues with our VM on Windows that will be fixed in the nearest future. To work around them, do the following:

  1. Important: Start Git Bash with elevated privileges (right-click and select Run As Administrator).
  2. Execute the following commands:
    cd ~/devvm
    rm -rf project
    mkdir project
    git clone https://github.com/spryker/demoshop.git ./project
    
  3. Open the Vagrantfile located in the devvm folder with a text editor (e.g. notelad.exe).
  4. Find the following lines:
    # View the documentation for the provider you are using for more
    # information on available options.
    
  5. Insert the following lines after them:
    config.vm.provider "virtualbox" do |v|
      v.customize ["setextradata", :id, "VBoxInternal2/SharedFoldersEnableSymlinksCreate/v-root", "1"]
    end
    
  6. Save the file.
  7. Return to Git Bash prompt and run vagrant up. This should do the job.

Best regards,

The Forum Team


#3

Thank you very much volodymyr, your notes were helps a lot to me, but when i run " composer install " command it showing below error.

Please help me with your feedback.


#4

Hello,
It looks like you are calling the command from Windows directly. You need to execute it inside the VM. Run vagrant ssh, wait for SSH login to your VM and then call composer install again.


Best regards,

The Forum Team


#5

Kindly help me, how can i find is SSH logged in to VM?, i run the commands “vagrant ssh” then “composer install” and also “vagrant up” as per suggestion while run command “vagrant ssh”.
Please check the screen below for more details.

Please help me with your valuable feedback. Thanks in Advance


#6

Judging by the error, the virtual machine is started, but Vagrant cannot perform an SSH login because the VT-x virtualization technology is not enabled on your computer. This technology is required by Virtualbox to enable management of the guest machine.

To fix the issue, boot to BIOS/UEFI and enable the VT-x option (sometimes, it is simply called Virtualization). If the option is not available or already enabled, see this Virtualbox forum post for additional workarounds.


Best regards,

The Forum Team


#7

Thanks for your suggestion, we run “vagrant up” , “vagrant ssh”. we get following statements screens. Please guide us, are we moving in correct way?


after this if we run “composer install”, we are facing following error screen.

please help with your comments.


#8

Hello,

It looks like you didn’t install the vagrant-vbguest plugin. Try the following:

vagrant plugin install vagrant-vbguest
vagrant ssh

Best regards,

The Forum Team


#9

Hello,

i executed commands as you suggested, now the screen will showing like this.

Please check the response from command and help me with your feedback.


#10

Hello,

Now, you need to start the virtual machine. Run commands exactly in the following sequence:

  1. vagrant up
  2. vagrant ssh
  3. composer install
  4. vendor/bin/install

Best regards,

The Forum Team