VM not loading on win 10


#1

I have windows 10.

I tried to install spryker today, using this instruction: https://academy.spryker.com/getting_started/installation_guide.html
I’ve installed vagrant and oracle vm from links in instruction.
First of all I got this error when i tried to run vagrant up: "fatal: could not create leading directories of ''C:/devvm/project’’: Invalid argument"

Ok, I’ve created it myself, then I got this error: “ERROR: The directory C:/devvm/project isn’t empty, yet it’s not a clone of spryker repository!

Ok, I checked the code and saw these lines:

elsif not Dir.entries(SPRYKER_DIRECTORY).include? 'setup’
raise "ERROR: The directory #{SPRYKER_DIRECTORY} isn’t empty, yet it’s not a clone of spryker repository!"
end

So I understand that I need to have cloned project using spryker in directory (btw, this error message is clearly incorrect, directory is obviously empty, we just not have file with name “setup” in it). I cloned project with git clone https://github.com/spryker/demoshop.git

Then i got next error, VBoxManage.exe: error: VT-x is disabled in the BIOS for all CPU modes (VERR_VMX_MSR_ALL_VMX_DISABLED)

I solved it disabling PAE/NX in the VM Settings -System - Processor.

Then I tried vagrant up one more time, i got timeout after very long waiting:

$ vagrant up
Loading VM settings file: .vm
Using vagrant-hostmanager to set hostnames: www.de.demoshop.local, zed.de.demoshop.local, www.at.demoshop.local, zed.at.demoshop
.local, www.us.demoshop.local, zed.us.demoshop.local, static.demoshop.local, www-test.de.demoshop.local, zed-test.de.demoshop.lo
cal, www-test.at.demoshop.local, zed-test.at.demoshop.local, www-test.us.demoshop.local, zed-test.us.demoshop.local, static-test
.demoshop.local
Bringing machine ‘default’ up with ‘virtualbox’ provider…
==> default: Clearing any previously set forwarded ports…
==> default: Fixed port collision for 22 => 2222. Now on port 2200.
==> default: Clearing any previously set network interfaces…
==> default: Preparing network interfaces based on configuration…
default: Adapter 1: nat
default: Adapter 2: hostonly
==> default: Forwarding ports…
default: 22 (guest) => 2200 (host) (adapter 1)
==> default: Running ‘pre-boot’ VM customizations…
==> default: Booting VM…
==> default: Waiting for machine to boot. This may take a few minutes…
default: SSH address: 127.0.0.1:2200
default: SSH username: vagrant
default: SSH auth method: private key
Timed out while waiting for the machine to boot. This means that
Vagrant was unable to communicate with the guest machine within
the configured (“config.vm.boot_timeout” value) time period.

If you look above, you should be able to see the error(s) that
Vagrant had when attempting to connect to the machine. These errors
are usually good hints as to what may be wrong.

If you’re using a custom box, make sure that networking is properly
working and you’re able to connect to the machine. It is a common
problem that networking isn’t setup properly in these boxes.
Verify that authentication configurations are also setup properly,
as well.

If the box appears to be booting properly, you may want to increase
the timeout (“config.vm.boot_timeout”) value.

I tried vb.gui = true option in vagrantfile to understand what is the problem, but i only see blackscreen here.

Can anyone help?


#2

Hi golem59,

It looks like you need to enable virtualization in your BIOS. Please boot to BIOS and looking around for an option labeled something like “Intel VT-x,” “Intel Virtualization Technology,” “Virtualization Extensions,” “Vanderpool,” or something similar and enable it. Hope it will help.


Regards,
Vladimir


#3

I did as you said - had enabled intel virtualization technology but still have same issue.


#4

Also I have run Laravel Homestead (from this link https://laravel.com/docs/5.4/homestead#installation-and-setup) without any problems, so it looks that only the spryker VM is not working.


#5

Any ideas? Can anyone confirm that last version is working correctly on your win10?


#6

Yes, I installed on Win 10 last week, and it worked fine. I still have some troubles with css files not found, but all steps described on spryker installation page finally executed w/o errors.


#7

I’m getting same error as well :frowning:

Hadi@DESKTOP-C2OQDKG MINGW64 ~/devvm
$ vagrant up

New VM settings will be used:
VM_PROJECT =         'demoshop'
VM_IP =              '10.10.0.190'
VM_MEMORY =          '3200'
VM_CPUS =            '4'
VM_NAME =            'Spryker Dev VM (demoshop)'
VM_DOMAIN =          'demoshop'
VM_SKIP_SF =         '0'
SPRYKER_BRANCH =     'master'
SPRYKER_REPOSITORY = 'https://github.com/spryker/demoshop.git'
Press return to save it in file .vm, Ctrl+C to abort
If the settings above are fine, they will be persisted on disk.
To change any setting, interrupt now and set environmental variable.
Cloning Spryker git repository...
checking for git... yes
fatal: could not create leading directories of ''C:/Users/Hadi/devvm/project'': Invalid argument
Using vagrant-hostmanager to set hostnames: www.de.demoshop.local, zed.de.demoshop.local, www.at.demoshop.local, zed.at.demoshop.local, www.us.demoshop.local, zed.us.demoshop.local, static.demoshop.local, www-test.de.demoshop.local, zed-test.de.demoshop.local, www-test.at.demoshop.local, zed-test.at.demoshop.local, www-test.us.demoshop.local, zed-test.us.demoshop.local, static-test.demoshop.local
Bringing machine 'default' up with 'virtualbox' provider...
There are errors in the configuration of this machine. Please fix
the following errors and try again:

vm:
* The host path of the shared folder is missing: C:/Users/Hadi/devvm/project