VM breaks when reloading


#1

MacOS Mojave 10.14.1
vagrant 2.2.2
VirtualBox 5.2.22 r126460 (Qt5.6.3)
vagrant-hostmanager 1.8.9 , global
vagrant-vbguest 0.16.0 , global
devvm1.0.4

Whenever I do vagrant up && vagrant halt && vagrant up or vagrant up && vagrant reload the vm crashes with this error:

    default: SSH address: 127.0.0.1:2222
    default: SSH username: vagrant
    default: SSH auth method: private key
Timed out while waiting for the machine to boot. This means that
Vagrant was unable to communicate with the guest machine within
the configured ("config.vm.boot_timeout" value) time period.

If you look above, you should be able to see the error(s) that
Vagrant had when attempting to connect to the machine. These errors
are usually good hints as to what may be wrong.

If you're using a custom box, make sure that networking is properly
working and you're able to connect to the machine. It is a common
problem that networking isn't setup properly in these boxes.
Verify that authentication configurations are also setup properly,
as well.

If the box appears to be booting properly, you may want to increase
the timeout ("config.vm.boot_timeout") value.
>>> elapsed time 5m35s

What do I need to do to fix this problem?

I tried to reinstall Vagrant, Virtualbox, destroy and up the vagrant, tried devvm2.1.0.

I can provide all infos that are needed if told how to get them.

Cheers!


#2

Hello,
This appears to be an issue with the new security features on Mojave. Try vagrant up in the default console or give the console app you are using full write permissions on the disk. Also, make sure you are using the latest versions of Vagrant and Virtualbox.


Best regards,
The Forum Team


#3

Hello!

I have SIP disabled, provided full access to iterm, virtualbox and the normal terminal.
I have updated to the latest versions of Vagrant and Virtualbox.

It’s not resolving the problem.


#5

The error is related to an updated kernel file in the Vargantfile Scripts we are running here. Might wanna look into that.