Vendor/bin/install fail


#1

This is under osx.

Command propel-diff for AT store [vendor/bin/console propel:diff] (In progress…)

In CommandLineExecutable.php line 70:

Aborted install…


#2

Hello,

can you provide more information about the error? You can run the install tool with -vv to get more output.

Thank you.


#3

Clean schema directory
Copy and merge schema files
Create diff

In MigrationDiffCommand.php line 104:

Uncommitted migrations have been found ; you should either execute or delet
e them before rerunning the ‘diff’ task


#4

Please check if the src/Orm/Propel/{STORE}/Migration_* directory contains any file. If so run vendor/bin/console propel:migration:delete and check if the files are still there. Maybe it’s a permission problem here.

Which VM Version do you use?


#5

VB 5.2.4
Vagrant 2.0.1

Yes, there are new files there.
Left by one of the previous scripts.
I deleted all the stores from the development file except DE
This managed to get the installation running to the end.


#6

Got the same problem.
Clear all files in "/data/shop/development/current/src/Orm/Propel"
I tried the command "vendor/bin/console propel:migration:delete"
After that the new install. Same problem.
Any other ideas or hints?


#7

I deleted all the stores from the development file except DE
This managed to get the installation running to the end.

config/install/development.yml edit the property “store”, delete all except DE
and run the install again.


#8

thanks petal,getnow.
that works perfect.


#9

Hi guys,
I have the same issue on iOS but at another command

Store: DE | Environment: development
Purge all queues
GuzzleHttp\Exception\ClientException - Exception: Client error: GET http://localhost:15672/api/queues/%2FDE_development_zed resulted in a 401 Unauthorized response:
{“error”:“not_authorised”,“reason”:“User not authorised to access virtual host”}

in /data/shop/development/current/vendor/guzzlehttp/guzzle/src/Exception/RequestException.php (111)

Command: vendor/bin/console queue:queue:purge-all

I deleted all the stores from the development file except DE, still it doesn’t work