Updating Spryker => No Layout in ZED


#1

Hello,

After updating Spryker, the ZED has no Layout, only unstyled Inputs/Buttons are shown.

I have executed the following commands:

  • frontend:install:package-manager
  • frontend:project:cleanup-dependencies
  • frontend:project:install-dependencies
  • frontend:yves:build
  • frontend:yves:install-dependencies
  • frontend:zed:build
  • frontend:zed:install-dependencies

Did I forget something?

After execute the command “npm run zed” Command, the following Errors are thrown:

ERROR in ./vendor/spryker/gui/assets/Zed/sass/main.scss

Module build failed: ModuleNotFoundError: Module not found: Error: Can’t resolve ‘jquery-ui/themes/base/all.css’ in ‘/srv/data/vendor/spryker/gui/assets/Zed/sass’
at factory.create (/srv/data/node_modules/@spryker/oryx-for-zed/node_modules/webpack/lib/Compilation.js:522:10)
at factory (/srv/data/node_modules/@spryker/oryx-for-zed/node_modules/webpack/lib/NormalModuleFactory.js:358:22)
at resolver (/srv/data/node_modules/@spryker/oryx-for-zed/node_modules/webpack/lib/NormalModuleFactory.js:118:21)
at asyncLib.parallel (/srv/data/node_modules/@spryker/oryx-for-zed/node_modules/webpack/lib/NormalModuleFactory.js:198:22)
at /srv/data/node_modules/neo-async/async.js:2817:7
at /srv/data/node_modules/neo-async/async.js:6783:13
at normalResolver.resolve (/srv/data/node_modules/@spryker/oryx-for-zed/node_modules/webpack/lib/NormalModuleFactory.js:188:25)
at doResolve (/srv/data/node_modules/enhanced-resolve/lib/Resolver.js:181:12)
at hook.callAsync (/srv/data/node_modules/enhanced-resolve/lib/Resolver.js:232:5)
at _fn0 (eval at create (/srv/data/node_modules/tapable/lib/HookCodeFactory.js:24:12), :15:1)
at resolver.doResolve (/srv/data/node_modules/enhanced-resolve/lib/UnsafeCachePlugin.js:37:5)
at hook.callAsync (/srv/data/node_modules/enhanced-resolve/lib/Resolver.js:232:5)
at _fn0 (eval at create (/srv/data/node_modules/tapable/lib/HookCodeFactory.js:24:12), :15:1)
at hook.callAsync (/srv/data/node_modules/enhanced-resolve/lib/Resolver.js:232:5)
at _fn0 (eval at create (/srv/data/node_modules/tapable/lib/HookCodeFactory.js:24:12), :12:1)
at resolver.doResolve (/srv/data/node_modules/enhanced-resolve/lib/DescriptionFilePlugin.js:42:38)
@ ./vendor/spryker/gui/assets/Zed/js/modules/commons.js 43:0-31
@ ./vendor/spryker/gui/assets/Zed/js/spryker-zed-gui-commons.entry.js

        ERROR in ./vendor/spryker/discount/assets/Zed/js/modules/libs/spryker-query-builder.js
        Module not found: Error: Can't resolve 'jquery-query-builder' in '/srv/data/vendor/spryker/discount/assets/Zed/js/modules/libs'
        @ ./vendor/spryker/discount/assets/Zed/js/modules/libs/spryker-query-builder.js 4:0-31
        @ ./vendor/spryker/discount/assets/Zed/js/modules/libs/sql-factory.js
        @ ./vendor/spryker/discount/assets/Zed/js/modules/main.js
        @ ./vendor/spryker/discount/assets/Zed/js/spryker-zed-discount-main.entry.js

        ERROR in ./vendor/spryker/product-relation/assets/Zed/js/modules/libs/sql-query-builder.js
        Module not found: Error: Can't resolve 'jquery-query-builder' in '/srv/data/vendor/spryker/product-relation/assets/Zed/js/modules/libs'
        @ ./vendor/spryker/product-relation/assets/Zed/js/modules/libs/sql-query-builder.js 8:0-31
        @ ./vendor/spryker/product-relation/assets/Zed/js/modules/main.js
        @ ./vendor/spryker/product-relation/assets/Zed/js/spryker-zed-product-relation.entry.js

        ERROR in ./vendor/spryker/gui/assets/Zed/js/modules/commons.js
        Module not found: Error: Can't resolve 'jquery-ui/ui/core' in '/srv/data/vendor/spryker/gui/assets/Zed/js/modules'
        @ ./vendor/spryker/gui/assets/Zed/js/modules/commons.js 15:0-28
        @ ./vendor/spryker/gui/assets/Zed/js/spryker-zed-gui-commons.entry.js

        ERROR in ./vendor/spryker/gui/assets/Zed/js/modules/commons.js
        Module not found: Error: Can't resolve 'jquery-ui/ui/effect' in '/srv/data/vendor/spryker/gui/assets/Zed/js/modules'
        @ ./vendor/spryker/gui/assets/Zed/js/modules/commons.js 16:0-30
        @ ./vendor/spryker/gui/assets/Zed/js/spryker-zed-gui-commons.entry.js

        ERROR in ./vendor/spryker/gui/assets/Zed/js/modules/commons.js
        Module not found: Error: Can't resolve 'jquery-ui/ui/effects/effect-highlight' in '/srv/data/vendor/spryker/gui/assets/Zed/js/modules'
        @ ./vendor/spryker/gui/assets/Zed/js/modules/commons.js 17:0-48
        @ ./vendor/spryker/gui/assets/Zed/js/spryker-zed-gui-commons.entry.js

        ERROR in ./vendor/spryker/gui/assets/Zed/js/modules/commons.js
        Module not found: Error: Can't resolve 'jquery-ui/ui/widget' in '/srv/data/vendor/spryker/gui/assets/Zed/js/modules'
        @ ./vendor/spryker/gui/assets/Zed/js/modules/commons.js 18:0-30
        @ ./vendor/spryker/gui/assets/Zed/js/spryker-zed-gui-commons.entry.js

        ERROR in ./vendor/spryker/gui/assets/Zed/js/modules/commons.js
        Module not found: Error: Can't resolve 'jquery-ui/ui/widgets/autocomplete' in '/srv/data/vendor/spryker/gui/assets/Zed/js/modules'
        @ ./vendor/spryker/gui/assets/Zed/js/modules/commons.js 20:0-44
        @ ./vendor/spryker/gui/assets/Zed/js/spryker-zed-gui-commons.entry.js

        ERROR in ./vendor/spryker/gui/assets/Zed/js/modules/commons.js
        Module not found: Error: Can't resolve 'jquery-ui/ui/widgets/button' in '/srv/data/vendor/spryker/gui/assets/Zed/js/modules'
        @ ./vendor/spryker/gui/assets/Zed/js/modules/commons.js 21:0-38
        @ ./vendor/spryker/gui/assets/Zed/js/spryker-zed-gui-commons.entry.js

        ERROR in ./vendor/spryker/gui/assets/Zed/js/modules/commons.js
        Module not found: Error: Can't resolve 'jquery-ui/ui/widgets/datepicker' in '/srv/data/vendor/spryker/gui/assets/Zed/js/modules'
        @ ./vendor/spryker/gui/assets/Zed/js/modules/commons.js 19:0-42
        @ ./vendor/spryker/gui/assets/Zed/js/spryker-zed-gui-commons.entry.js

        ERROR in ./vendor/spryker/gui/assets/Zed/js/modules/commons.js
        Module not found: Error: Can't resolve 'jquery-ui/ui/widgets/sortable' in '/srv/data/vendor/spryker/gui/assets/Zed/js/modules'
        @ ./vendor/spryker/gui/assets/Zed/js/modules/commons.js 22:0-40
        @ ./vendor/spryker/gui/assets/Zed/js/spryker-zed-gui-commons.entry.js

        ERROR in ./vendor/spryker/gui/assets/Zed/js/modules/commons.js
        Module not found: Error: Can't resolve 'jquery-ui/ui/widgets/tooltip' in '/srv/data/vendor/spryker/gui/assets/Zed/js/modules'
        @ ./vendor/spryker/gui/assets/Zed/js/modules/commons.js 23:0-39
        @ ./vendor/spryker/gui/assets/Zed/js/spryker-zed-gui-commons.entry.js

        ERROR in ./vendor/spryker/discount/assets/Zed/js/modules/libs/spryker-query-builder.js
        Module not found: Error: Can't resolve 'sql-parser/browser/sql-parser' in '/srv/data/vendor/spryker/discount/assets/Zed/js/modules/libs'
        @ ./vendor/spryker/discount/assets/Zed/js/modules/libs/spryker-query-builder.js 3:19-59
        @ ./vendor/spryker/discount/assets/Zed/js/modules/libs/sql-factory.js
        @ ./vendor/spryker/discount/assets/Zed/js/modules/main.js
        @ ./vendor/spryker/discount/assets/Zed/js/spryker-zed-discount-main.entry.js
        ✘ build failed

#2

Hi @nxslutz,

build commands should be executed after install-dependencies.

Best regards
Valerii


#3

Okay, thank you for your answer