The property "translator" nor one of the methods "translator()", "gettranslator()"/"istranslator()" or "__call()" exist


#1

Neither the property “translator” nor one of the methods “translator()”, “gettranslator()”/“istranslator()” or “__call()” exist and have public access in class “Spryker\Shared\Kernel\Communication\Application” in “@Gui/Layout/layout.twig” at line 91.

This is after running composer update on our spryker shop suite today, was there a new requirement (breaking change) released as a minor patch?


#2

Hi Jan,

Yes, unfortunately you are right. We have a BC break in Gui module, will provide fix very soon.
Sorry for inconvenience.

Best regards,
Valerii


#3

Here is the patch - https://github.com/spryker/gui/releases/tag/3.17.1.

Best regards,
Valerii