Spryker/silex conflict with spryker/symfony:^3.0.0


#1

Hi everyone,

I discovered today that there is a conflict between spryker/silex and spryker/symfony

Spryker/silex required silex/silex ^1.3.5
Spryker/symfony required symfony/security: ^2.6.13 || ^3.0.0

With silex on version 1.3.6 and Symfony/security on version 3.2.13 (the same as Spryker-shop/suite) there is a great problem:

In YvesBootstrap is registered the service provider “SecurityServiceProvider” von Silex/Provider. In this version (1.3.x) the service provider required the deprecated SecurityContext von Symfony/security that is not more present in version ^3.0.0 .

How can I resolve this problem? Override the silex SecurityServiceProvider?

Thanks in advance.

BR
Gio


#2

Hi Giovanni,

Have you faced with some exceptions here?

When you open the Silex\Provider\SecurityServiceProvider you can see that SecurityContext and SecurityContextInterface are undefined.
BUT
In symfony/security 2.6 SecurityContext was deprecated and the usage of it was replaced with the AuthorizationChecker and the TokenStorage. $app['security'] is not used anymore and dead code which is removed in newer silex versions.
There is nothing to fix. It is not used. Just undefined classes, but they aren’t used in our cases.

Best regards
Valerii


#3

Hi Valerii,

thank you very much for your reply.

BR
Gio