Spryker install No VM


#21

Hi @mzieger,

Have you enabled rabbitmq_management plugin - “sudo rabbitmq-plugins enable rabbitmq_management”?
If so, please check that the mentioned user has permissions like on the attached screenshot.

WBR
Valerii


#22

Hei @tvalerii,

yes, the plugin is enabled and the user has the correct permissions.
also from the vhost perspective
grafik

regards,
Michael


#23

Michael, could you please provide the part regarding rabbitmq in Spryker’s configs?

WBR
Valerii


#24

Hei @tvalerii,
my configs are quite easy.
I installed the stack on one fresh AWS EC2 machine, according to minimum requirements (see stack versions above)
I tried to setup the demoshop without VM (like the description: https://academy.spryker.com/getting_started/installation_guide_no_vm.html).
I cloned the repository: https://github.com/spryker-shop/suite.git.
And than I tried to continue with “Install the Application” (like: https://academy.spryker.com/getting_started/installation_guide.html)
But than vendor/bin/install failed.
Than I remembered having seen some architecture presentation mentioning RabbitMQ, so I installed this one to and with the following error I ended up with the discussion here and the advice to config the users and vhosts for RabbitMQ.
So my config is like the config from the repo.

The actual problem at the moment is, like mentioned above:

PhpAmqpLib\Exception\AMQPProtocolChannelException - Exception: ACCESS_REFUSED - access to exchange ‘event’ in vhost ‘/DE_development_zed’ refused for user ‘DE_development’
in /var/www/html/project/vendor/php-amqplib/php-amqplib/PhpAmqpLib/Channel/AMQPChannel.php (188)

Command: vendor/bin/console queue:queue:purge-all

Do you have any hint what could cause the problem?
Or is there any other more detailed installation manual how to set up the demoshop on an fresh cloud server (beside the ones on the website), because we want to have one example where all project members can get hands-on the demosystem even QA to get a feeling how it’s working.

thank you for you patience :slight_smile:
regards,
Michael


#25

Hi Michael,
Have you added RabbitMQ configuration to you config/Shared/config_local.php?
You need to add something like this:


Best regards,
Vladimir


#26

Hei @vvs,

thanks.
Ok, i added the config_local.php manually to that directory with the content of that file, including the marked rabbitmq part.
But it also says that the file is actually truncated (?)
But ok, it seems to work…but the next problem vendor/bin/install is


#27

Michael,
It looks like you don’t have the environment variables (RABBITMQ_HOST, RABBITMQ_API_PORT, RABBITMQ_USER, RABBITMQ_PASSWORD, RABBITMQ_VHOST) set, which used in the config/Shared/config_local.php. You need to set it first, for example:

export RABBITMQ_HOST=localhost
...

There are empty env variables are substituted in your config/Shared/config_local.php at this moment.


Best regards,
Vladimir


#28

Hei @vvs,
ok, it worked somehow.
I also added some more infos for elastic etc.
and now I stuck again within “section database-flush”


I would guess that the credentials for the local postgres might missing, but i put them st the end of config_local.php
Any hint here, please :slight_smile:
Thank you a lot.
Michael


#29

Michael,
You need to set PGPASSWORD environment variable with your Postgres password, like this:


Best regards,
Vladimir


#30

Hei @vvs,
thanks for that hint.
We got a new and reoccuring problem with the postgres during vendor/bin/install
SQLSTATE[42P07]: Duplicate table: 7 ERROR: relation "spy_sales_reclamation_pk_seq" already exists

I already deleted the db again, but still the same error during the installation.
Beside that the postgres user has rights for “create db”, are there anymore needed?

Regards,
Michael


#31

Good day mzieger!

This issue happens due to the bug in Propel migration tool, which doesn’t validate presence of sequence.
Also, please make sure to commit migrations into repository when you have a process of handling those.
One might have outdated DB, and applying migrations in a wrong order, which is common thing to happen after merging branches, will not work.

Andrey


#32

Hei @Andrey_Tkachenko,

it’s just the initial setup of the demoshop on a fresh server from the demoshop master branch.
Somehow i would not expect migriation problems just installing the demo.

Michael


#33

Hi, mzieger

The thing is, if you tried once to install shop, and didn’t drop DB, all sequences would be still present in the DB.
If possible, please;

  • remove all migrations,
  • use new DB,

Andrey