Setup issues with a windows machine


#1

I have setup the dev environment on a Windows 7 machine. I had some problems (and solutions) that I want to share here. I hope this is Ok.

1: Setup fails if you don’t have a Github account AND - in advance - add your new (or existing) SSH key to your GitHub account. Workaround: If you want to checkout without an account you have to change the Github URL in _Vagrantfile`

# Remote locations of repositories
# this is for use with github account
# SPRYKER_REPOSITORY = ENV['SPRYKER_REPOSITORY'] || "git@github.com:spryker/demoshop.git"
# this is for use without account
SPRYKER_REPOSITORY = ENV['SPRYKER_REPOSITORY'] || "git://github.com/spryker/demoshop.git"

2: Setup fails again because setup tries to use an invalid path within Windows. In box.ovf you will find

<vssd:VirtualSystemIdentifier>Spryker Dev VM (build: ci-53) </vssd:VirtualSystemIdentifier>

but the : (colon) is not allowed within a Windows path.

Workaround: replace each occurrence of ‘(build: ci-53)’ by ‘(build ci-53)’

3: zsh is not working well with Virtualbox. Shell becomes slow and does some erratic things with the prompt. The Installation Guide says

"Your local code installation will be mounted as a network share inside the 
VM to /data/shop/development/current. Inside this folder, composer and npm will be used to install 
additional dependencies."

Within this setup the script setup-frontend.sh is called. Within this script NPM is called:

sudo $NPM install -g github:spryker/antelope

Called from zsh this fails because of file system rights incompatibility.

Workaround: When this script is run from bash-shell it will work and setup completes.


#2

Hi there,

I also installed the spryker about 2 weeks ago on Win7 and Win10

Although I ran the cmd with Admin rights, it couldn’t create the “project” folder, the only workaround I found was to create myself the folder, and inside git glone the demo-shop resources.

After this the vagrant machine was up.

The next step was to run the command “./setup -i”. It failed when installing the npm packages.
To make this work I had to remove the node_modules folder and run the command “npm install --no-bin-links”.
To make the setup work I had to comment the if statement that deleted the npm_modules folder in the bash function cleanupProjectFrontendDeps.

Only after these changes the command “./setup -i” worked.

The project know works but the page load for yves and zed is very slow, at least 20-30 seconds.

Hope this is usefull for somebody.
Cosmin

PS: I tried to install the project on a MAC, the installation worked perfectly, no errors and very very fast, also the pages have a decent load time.


#3

Hi,

according to Cosmin and the symlink Problem on Windows. First I solved the Problem the same way with the command “npm install --no-bin-links”. Later it worked for me to extend the Vagrantfile.

Add in Vagrantfile

#Enable Symlinks on SharedFolders
config.vm.provider "virtualbox" do |v|
    v.customize ["setextradata", :id, "VBoxInternal2/SharedFoldersEnableSymlinksCreate/v-root", "1"]
end

Hope it’ll help somebody,
Melina