Middelware requires spryker/development package

Goal

We would like to remove test directories in production images.

Problem

Warning: require(/var/www/vendor/composer/../spryker/development/tests/dd.php): failed to open stream: No such file or directory in /var/www/vendor/composer/autoload_real.php on line 6
  1. spryker-middleware/process requires spryker/development and
  2. spryker/development loads tests/dd.php (see “files” section in https://github.com/spryker/development/blob/master/composer.json) with EVERY php execution.

Solution

move spryker/development from “require” to “require-dev” section in https://github.com/spryker-middleware/process/blob/master/composer.json?

Hi Lars,

thank you for reporting this issue. I will create a support ticket in your favor in our support portal - http://support.spryker.com/. And will keep you updated from there.

Have a nice weekend!

Best,
Valerii Trots
Customer Support Engineer