Installation: http://zed.de.demoshop.local/ return "Missing setup for store: DE"


#1

Hello, I spent about 10 hours to setup Spryker. Now I face this problem: after successful ./setup -i navigation to http://zed.de.demoshop.local/ give the stack tracte below.

Can somebody help?

Regards, Dominik

error: Uncaught Exception: Missing setup for store: DE in /data/shop/development/current/vendor/spryker/kernel/src/Spryker/Shared/Kernel/Store.php:141 Stack trace: #0 /data/shop/development/current/vendor/spryker/kernel/src/Spryker/Shared/Kernel/Store.php(156): Spryker\Shared\Kernel\Store->getStoreSetup(‘DE’) #1 /data/shop/development/current/vendor/spryker/kernel/src/Spryker/Shared/Kernel/Store.php(118): Spryker\Shared\Kernel\Store->initializeSetup(‘DE’) #2 /data/shop/development/current/vendor/spryker/kernel/src/Spryker/Shared/Kernel/Store.php(97): Spryker\Shared\Kernel\Store->__construct() #3 /data/shop/development/current/vendor/spryker/config/src/Spryker/Shared/Config/Application/Environment.php(32): Spryker\Shared\Kernel\Store::getInstance() #4 /data/shop/development/current/public/Zed/index.php(13): Spryker\Shared\Config\Application\Environment::initialize() #5 {main} thrown in /data/shop/development/current/vendor/spryker/kernel/src/Spryker/Shared/Kernel/Store.php on line 141


#2

Hi Dominik,
do you already have a Spryker VM installed on your computer?
You have to make sure that domain name and IP-Adress are different when setting up the vagrant machine.


#3

Hey @Dominik_Kraipl,

have you been able to resolve the issue?

i have the same error message after successful installation when reaching the VM via IP.
The VM is only reachable via ip not the http://zed.de.demoshop.local/ domain.

Thanks in advance,

roman


#4

Hello,

i have the same issue like @Dominik_Kraipl! It would be great if someone have an idea to solve it.

When starting “vagrant up” i got an npm failure errorcode 71. So I “npm install --no-bin-links”.

I can reach the VM via IP (Hostmanager can’t edit host config on Windows10) but i get the same PHP Fail.

Thank you in advance


#5

It seems, that you need the URLs to open the pages. Edit the host file manually:

10.10.0.190 www.de.demoshop.local
10.10.0.190 zed.de.demoshop.local

Maybe “ask” ifconfig on your VM for the IP.