Installation guide and Problem with Windows10 B2C VM Installation


#1

Dear Spryker Team,

the layout / theme theme of your instalation guide is a little bit miss-fitting the screen.
(like here: https://documentation.spryker.com/installation/installation-guide-b2c.htm#windows)


There is an enormous white-space on the left side and almost all code-boxes sticking out even with a full-screen HD monitor.
it’s quite easy to miss some parts of code or even to see that there is a button to copy the code.

Anyhow - whenI tried the “last” windows guide before the splitting into b2b and b2c it worked very well.
But the b2c guide is just stucking an Step 2.4

I already deleted all stuff from the VM and the directory again and rebooted, but it will die everytime on the same step.

May be you could help me a little?

Best regards
Michael


#2

Hi @mzieger,

Thank you for the report, our documentation team is aware about this problem and already on it.

Error about “could not read from remote repository” sounds for me like some problems with ssh-keys. Try to run ssh-add command if it’s available in Windows and then try it once more.

Best regards,
Valerii


#3

Hello @mzieger,

Regarding the could not read from remote repository error, on step 2.4., do the following:

  1. Execute export VAGRANT_PREFER_SYSTEM_BIN=1
  2. Execute VM_SKIP_SF="1" VM_PROJECT=b2c-demo-shop SPRYKER_REPOSITORY="git@github.com:spryker-shop/b2c-demo-shop" vagrant up again.

This should fix the issue.


Regards,

The Forum Team


#4

same error, not working. sorry


#5

I just found another way and got it up running.

  • change Virtual Box version to 5.2.8
  • extend step 1: install vagrant plugin install vagrant-winnfsd

then run the installation guide as shown in the documentation

but afterwards I stopped it with vagrant halt and voila next day it’s not working again with vagrant up


#6

vagrant-winnfsd plugin is very buggy and cannot be recommended for daily activities. There are several known major problems with it.

PHP file_put_contents does not work properly

In some cases, specifically occurred when using Composer, the PHP function file_put_contents returns the number of written bytes like expected and the file is created, but it’s empty. This causes a bug in Composer. Sometimes the problem can be solved by deleting the file, sometimes by reloading Vagrant, sometimes it can’t be solved at all. See: https://github.com/winnfsd/vagrant-winnfsd/issues/104

As a workaround, the following command, run in Powershell (as admin) will exclude winnfsd from Defender’s eye.

Add-MpPreference -ExclusionProcess winnfsd.exe

Symlinks are not supported

When installing frontend, npm uses symlinks for "node_modules", and this will not work on Windows.

$ ln -s ~/foo bar

ln: failed to create symbolic link ‘bar’: Input/output error

No proper solution or workaround could be found for this problem. Only running npm i --no-bin-links will not create symlinks.