Installation fails on MacOS Mojave due to enabled SIP


#1

With SIP enabled, the installation stucks on Mounting NFS shared folders...

A possible solution is to disable SIP: hashicorp/vagrant#10234 (comment)

How to disable: https://www.howtogeek.com/230424/how-to-disable-system-integrity-protection-on-a-mac-and-why-you-shouldnt/

After disabling SIP, the vagrant installation routine works.

You really should NOT disable SIP permanently. There’s a reason for it being there!


#2

Try a solution from @ehsan.zanjani

if you have any problem with Vagrant or VirtualBox please update the VBox to the latest Test Build to resolve the issue, you can download it from https://www.virtualbox.org/wiki/Testbuilds


#3

It is possible to give full access disk to Terminal or iTerm and after that NFS Mounting works fine.

BR
Gio


#4

I tried that with no success. So I took the SIP disable solution. But I will try to update the latest VB


#5

Yes you are right we need to disable the SIP before the installation and then enable it back:
here you can find the steps:

Disable System Integrity Protection (SIP)

Yes, yes, I also hate this, but has to be done until Apple refreshes the list of allowed Kernel Extensions to allow VBoxDrv.kext to load properly in Mojave.

  1. Reboot your Mac and hold Command + R (⌘ + R) before it boots.
  2. Keep holding it until you see the progress bar
  3. Wait for it to finish
  4. At the top menu, select Utilities -> Terminal
  5. Enter csrutil disable
  6. Press Enter
  7. Type reboot

After this is solved, do the same steps to re-enable SIP, but type csrutil enable at Step 5.

For more info check this https://silvae86.github.io/sysadmin/mojave/beta/vagrant/virtualbox/osx/macos/2018/07/10/running-vagrant-and-virtualbox-in-mojave-public-beta