In spryker-shop/suite is a bug if i use zed with port


#1

If i use zed with a different port, there is a bug in method:
vendor/spryker/application/src/Spryker/Zed/Application/Communication/Plugin/ServiceProvider/AssertUrlConfigurationServiceProvider.php

protected function assertMatchingHostName(Request $request)

There is a compare from getHttpHost with getHostName. GetHttpHost return the given host with port, but the getHostName only return the host without port.

Then in zed you get this error:
Incorrect HOST_ZED config, expected zed.de.suite.local:10000, got zed.de.suite.local. Set the URLs in your Shared/config_default_DE.php or env specific config files.

Also before it was possible to configure a different host for yves to zed communication and zed gui. Now i can’t find this option.


#2

This seems to be indeed a problem that we didn’t account for yet.
Until it is fixed, please just disable these development only service providers.
They are only there to help you to have the right domains configured.


#3

Is this issue fixed right now? At the moment i get

Incorrect HOST_ZED config, expectedlocalhost, gotlocalhost:20200. Set the URLs in your Shared/config_default_DE.php or env specific config files.

in my docker environment. I am sure, i hadn’t this error last time.

Best regards