Docker-sync start error in Bash while setup demoshop in Windows(Docker)


Hi, while i am trying to installing the Spryker by using setup of demoshop in Docker, but docker sync start is not working, it is giving error like attached screen

. Please help to move forward, thanks in advance.


Did you make step 13 with adding docker-sync.yml file (with configuration of docker-sync)? It is in the last block of the document:


Thanks you for reply,

I added docker-sync.yml file in demoshop root folder, i am giving the file code below please check and help with your feedback.

docker-sync.yml code:

-----------code start-------------------
version: “2”
verbose: true
app-sync: # tip: add -sync and you keep consistent names als a convention
sync_args: [’-perms=0’] #required for two way sync ie generators, etc
sync_strategy: ‘unison’
sync_host_ip: ‘’ #host ip isn’t properly inferred

sync_excludes: [’.gitignore’, ‘.idea/’,’.git/’, ‘.coffee’, '.scss’, ‘.sass’,’.log’]

src: '/mnt/c/Users/GSS_DELL/demoshop'
sync_userid: '33'

--------------code ends-------------------

if i click on" " link, then one file is downloading which contains “waiting for deploy page” message.


It looks like you had canceled the previous installation process of Spryker to your docker volume and the volume has inconsistent data.
So, I recommend you to delete the docker volume with:

docker volume rm app-sync

(If you will got the error that volume is in use, you need also delete the appropriate docker container with docker rm ...)
After that you could try to make the installation from the scratch with the installation guide.

Best regards,


Hi Vladimir, thanks for your valuable feedback, i executed some commands as shown in screenshot, please confirm with your feedback i am doing correct way or not, kindly correct me if i’m wrong. please help me.

i executed command “docker volume rm app-sync” in command prompt as like this

please correct me with your valid command if i’m wrong.

Finally i got this error screen at end of the installation.



It looks like you didn’t perform sudo gem install docker-sync (step 8 of block Developing with Docker (docker-sync)).

Best regards,

The Forum Team


Thank you very much, it works, but after run this commands below
sudo gem install docker-sync
cd /mnt/c/Users/$USER/demoshop
docker-compose up -d
docker-sync start

i am getting this below error

please help me



Did you change the default docker-sync file? Option dirname is not used in it.

Best regards,

The Forum Team



Yes, i updated it, please check my docker-sync.yml file content. my demoshop folder is existed in following path


docker-sync.yml file code :

version: “2”
verbose: true
app-sync: # tip: add -sync and you keep consistent names als a convention
#sync_args: [’-perms=0’] #required for two way sync ie generators, etc
sync_strategy: ‘unison’
sync_host_ip: ‘’ #host ip isn’t properly inferred
#sync_excludes: [’.gitignore’, ‘.idea/’,’.git/’, ‘.coffee’, '.scss’, ‘.sass’,’.log’]
src: ‘/mnt/c/Users/GSS_DELL/demoshop’
sync_userid: ‘33’

i updated all the below commands successfully in Bash to Develop demoshop with Docker:

sudo apt install docker-compose
sudo apt-get install ruby ruby-dev
sudo gem install docker-sync
sudo apt-get install ocaml make emacs
tar xvf v2.51.2.tar.gz
cd unison-2.51.2
make UISTYLE=text
sudo cp src/unison /usr/local/bin/unison
sudo cp src/unison-fsmonitor /usr/local/bin/unison-fsmonitor
cd /mnt/c/Users/$USER/demoshop
docker-compose up –d

Error raised command in Docker installation

docker-sync start


According to your screenshot “basename: missing operand” i had the same error in WSL when testing the official spryker docker setup for demoshop and spryker suite.

check your WSL configuration.

readlink /etc/localtime should return a timezone.
If not -> configure it
sudo dpkg-reconfigure tzdata

(When you have a look to the docker run… docker-sync generated command you see its using the $(basename…readlink etc…)) use this parts to debug your env


I had completed set the time zone here(Asia/Kolkata) with this commnad “sudo dpkg-reconfigure tzdata”, but i am unable to get this following statement, can you please give some explanation about this below statement.

“[When you have a look to the docker run… docker-sync generated command you see its using the $(basename…readlink etc…) use this parts to debug your env.]”

Please help me


docker-sync is passing your system time settings to their own sync container as an env variable TZ.
I guess they are using it for file datetime comparisons to detected changes in your volumes and keep their data sync container up to date.

You can find more help here:

Is ‘docker-sync start’ working now?


i executed this command “sudo gem install docker-sync”, for “brew: not found” error executed command “sudo apt install linuxbrew-wrapper”,then executed “docker-sync start” command, now we are getting following screen.

please help me specially on following comments in above screenshot, i cant understood.

  1. /var/lib/gems/2.3.0/gems/docker-sync-0.5.7/lib/docker-sync/update_check.rb:42: warning: Insecure world writable dir /mnt/c in PATH, mode 040777
  2. Error: No such keg: /home/prathapt29/.linuxbrew/Cellar/unox
  3. dirname: missing operand
    Try ‘dirname --help’ for more information.
  4. basename: missing operand
    Try ‘basename --help’ for more information.

please help me

  1. its just a warning - between windows <-> WSL created files. You can fix this by chmod your sync src to “better” permissions. But you dont have to.
  2. Maybe this helpful?
    3+4. Whats the result if you execute
    $(basename $(dirnamereadlink /etc/localtime))/$(basenamereadlink /etc/localtime)
    in WSL like docker-sync is doing? => i.e. i receive
    -bash: Europe/Amsterdam: No such file or directory
    Did you check if /etc/localtime exist in your WSL filesystem?

PS: I am also getting sh: 1: brew: not found but got no linuxbrew-wrapper installed. Its working without it…


Finally we are getting this screen with result, is docker-sync started in background?
And also needed some solution from you to give permission for following warning:
“/var/lib/gems/2.3.0/gems/docker-sync-0.5.7/lib/docker-sync/update_check.rb:42: warning: Insecure world writable dir /mnt/c in PATH, mode 040777”

and also check the below screen and let me know where we are in installation process and what we have to do for completing the total installation.

Thanks in advance, please help me.



It looks like the synchronization have started in the background. Can you check whether Unison is populating C:\Users\GSS_DELL\demoshop with files? if yes, then you just need to wait until Unison finishes copying the files, and you are ready to start developing :slight_smile:

The Forum Team


Unison is not populating C:\Users\GSS_DELL\demoshop folder, can you please tell where we went wrong, please guide me?

please check below screen which contains folder/file structure and details in demoshop, is this correct unison folder which you are expecting in demoshop folder.


please give me some idea about issues selected with red color in below screen.

Please help me.