Demoshop is really slow (on Win7)


#1

Hello,

the demoshop and zed load really slow. Often i get a 504 Gateway Time-out. Did someone have the same problem and an idea to the solution?

I installed the VM on Windows 7.

Thanks in advance,
Melina


#2

Hi Melina,

Which hardware parameters do you currently have on your PC (RAM, CPU, HDD/SSD)?
Could you check your Resource Monitor during using Demoshop?


Best regards,
Vladimir


#3

Hello Vladimir,

I have
Processor: Intel® Core™ i5-6300 CPU @ 2.40 GHz 2.50 GHz
RAM: 8 GB
System: 64 Bit-Operating System
SSD sandisk x400 M.2280 25 scsi

VM Settings are
VM_MEMORY = '3000’
VM_CPUS = ‘2’

The Resource Monitor shows a strong utilization of the working memory, just about 82%. It doesnt matter if i use Demoshop or have just an ongoing VM.
The CPU increases to ~50% while using Demoshop.

I had tried different settings for the vm, but without result. Do you have an idea?

Kind regards,
Melina


#4

Melina,
Your hardware looks ok.
Please, check if you have the VM setting:
VM_SKIP_SF=1
which will not use shared folders. Might be it helps.


Best regards,
Vladimir


#5

Good Mornig Vladimir.

I tried your proposal immediately. Unfortunately there is no difference in utilization of the working memory between VM_SKIP_SF= 1 or 0.


#6

Melina,
Just for sure, did you add VM_SKIP_SF=1 to your VirtualBox configuration file and restart your Vagrant VM?


Best regards,
Vladimir


#7

Hello Vladimir,

yes, I did it this way in the morning, when nothing else was running on the laptop. I edited the .vm file, not the settings in VirtualBox.

In the screen you can see, when the signal goes down, it was “vagrant halt”

Best regards,
Melina


#8

Hi Melina,
Could you please try to start:

ls -lAR

command inside the Vagrant VM?


Best regards,
Vladimir


#9

Hi Vladimir,

i´m very pleased to hear from you. Thanks.
What are you looking for in the result list? It is to long to screenshot it completely.

Kind regards,
Melina


#10

Melina,
It is recursively re-index all files of the projects and helped in some cases for MacOS installations. Most probably that it doesn’t help for Windows, but you could try it for sure. The output shows all files in your project tree and it doesn’t matter for checking.


Best regards,
Vladimir


#11

Hello,
I experience the very same issue on windows 8.
My vagrant box is terribly slow. In my case, hardware can’t be the bottleneck:
I gave 10gb ram to the virtual machine, and 4 cpus.

Can anybody help?


#12

Thanks Valdimir, but it does not cause any change.

I tried to switch to file type nfs, but no change in percormance. (https://github.com/winnfsd/vagrant-winnfsd)


#13

Hello,

I have the same problem, on Win7 is runing very slow. like 20-30 seconds to load a page.
Today I tried to install the project on a MAC and everything was super ok and the setup worked real nice. The page load was decent.
I think the issue is on Windows.

Thanks,
Cosmin


WIN 10 VM: Running super slow
#14

Same problem here… on a Windows 10 64 bit machine:

  • 8GB RAM,
  • SSD
  • i5-8250U
  • Vagrant 2.1.1
  • VirtualBox 5.2.12 r122591 (Qt5.6.2)
  • using Firefox 52.8.1

Result: