Cannot debug bundle


#1

I installed spryker using the provided vagrant - box.

This worked just fine and I also installed xdebug accordingly (following this http://spryker.github.io/getting-started/installation/debugging-setup/)

Xdebug seems to work in generel, because I’m able to debug spryker core files.
However, I’m not able to debug code in calculator/tax bundle.

I followed this tutorial ( http://spryker.github.io/tutorials/zed/calculator-plugin/) and did some recalculation of the grandTotal

 <?php namespace Pyz\Zed\Tax\Business\Model;

use Generated\Shared\Transfer\QuoteTransfer;
use Spryker\Shared\Log\LoggerTrait;


class ItemTaxCalculator
{


    use LoggerTrait;

    public function recalculate(QuoteTransfer $quoteTransfer)
    {
        $totalsTransfer = $quoteTransfer->getTotals();
        $totalsTransfer->setGrandTotal(999);
    }
}

I can see that the grandTotal changed, but the debugger wont’ stop at the breakpoint.

However I can see that the code works, because I logged it and see the result in the card.
I can debug other scripts just fine (like Generated\Shared\Transfer\QuoteTransfer::setGrandTotal )

Any help would be great


#2

Hi,

If you are trying to debug Zed from Yves (e.g. curl a request to Zed is fired then in PhpStorm you probably have to increase “Max. simultaneous connections” to 2 (under Debug menu).


#3

Hi,

thanks for trying to help me.
I already have this setting set to 2 - according to the documentation


#4

Did you tried to set multiple breakpoints on other lines? I am experiencing a similar issue but not with a non working debugger at all but much more with a not synced debugger. My IDE is always one line ahead the debugger in vm seems to be …