Cache problems, maybe?


#1

When i edit a controller or a template, it doesn’t get refreshed right away.
I have to wait 10-20 seconds to see the result when i do a request via the browser.
Is there a way to disable caching globally on DEV, if that is the problem?


#2

Hi Petar,

This sounds like you have opcache enabled. Have you checked your php opcache settings in the VM?
In demoshop under http://zed.de.demoshop.local/maintenance/php-info url you can see your php info. To change opcache config edit the
/etc/php/7.1/mods-available/opcache.ini file.


#3

Yea, it was the opcache.
I had already looked for it but in the wrong php version.
Thanks


#4

After i reloaded the VM, the problem is back.
The opcache is disabled 100% and when i edit a controller it throws an exception at ClassLoader->includeFile();

When i run some commands to check on the edited file i see.

Command : ls -la

Before editing : -rw-r–r-- 1 502 dialout 636 Jan 5 13:49 IndexController.php

After editing : -??? ? ? ? ? ? IndexController.php

Something at a lower level is going wrong, have no idea.


#5

This is only happening for modules generated by the console code:generate:module


#6

The problem was PHPStorm, the latest version.

Version: 2017.3.2
Build: 173.4127.29
Released: December 22, 2017