Blank Page after Installation

Hi there,
On Linux installation without vm with the needed systemrequirements the Zed Website is empty.
It Only contains empty head an body

Here is my zed Vhost:

server {
server_name zed.de.spryker.local;
listen 80 ;
access_log /var/log/nginx/zed.de.spryker.local.access.log;
root /home/pbeothig/Dokumente/spryker/public/Zed;

Timeout for Zed requests - 10 minutes

(longer requests should be converted to jobs and executed via jenkins)

proxy_read_timeout 600s;
proxy_send_timeout 600s;
fastcgi_read_timeout 600s;
client_body_timeout 600s;
client_header_timeout 600s;
send_timeout 600s;

Static files can be delivered directly

location ~ (/images/|/scripts|/styles|/fonts|/bundles|/favicon.ico|/robots.txt) {
access_log off;
expires 30d;
add_header Pragma public;
add_header Cache-Control “public, must-revalidate, proxy-revalidate”;
try_files $uri =404;
}

Payone - PHP application gets all other requests without authorized

location /payone/ {
auth_basic off;
add_header X-Server $hostname;
try_files $uri @rewriteapp;
}

location ~ .php$ {
#include snippets/fastcgi-php.conf

With php7.1-cgi alone:

#   fastcgi_pass 127.0.0.1:9000;
#   # With php7.1-fpm:
   fastcgi_pass unix:/run/php/php7.3-fpm.sock;

}

PHP application gets all other requests

location / {
#add_header X-Server $hostname;
try_files $uri @rewriteapp;
#more_clear_headers ‘X-Powered-By’ ‘X-Store’ ‘X-Locale’ ‘X-Env’ ‘Server’;

}

location @rewriteapp {
# rewrite all to app.php
rewrite ^(.*)$ /index.php last;
}

}

Problem found. If you install manually you have to configure yout site in /etc/nginx/sites-xxx correctly.

The documentation lacks the correct php location :slight_smile:
Here is my working site definitin for zed under /etc/nginx/sites-enables/zed.conf

server {
server_name zed.de.spryker.local;
listen 80 ;
access_log /var/log/nginx/zed.de.spryker.local.access.log;
root /home/pbeothig/Dokumente/spryker/public/Zed;

Timeout for Zed requests - 10 minutes

(longer requests should be converted to jobs and executed via jenkins)

proxy_read_timeout 600s;
proxy_send_timeout 600s;
fastcgi_read_timeout 600s;
client_body_timeout 600s;
client_header_timeout 600s;
send_timeout 600s;

Static files can be delivered directly

location ~ (/images/|/scripts|/styles|/fonts|/bundles|/favicon.ico|/robots.txt) {
access_log off;
expires 30d;
add_header Pragma public;
add_header Cache-Control “public, must-revalidate, proxy-revalidate”;
try_files $uri =404;
}

Payone - PHP application gets all other requests without authorized

location /payone/ {
auth_basic off;
add_header X-Server $hostname;
try_files $uri @rewriteapp;
}

location ~ [^/].php(/|) { fastcgi_split_path_info ^(.+?\.php)(/.*);
if (!-f $document_root$fastcgi_script_name) {
return 404;
}

# Mitigate https://httpoxy.org/ vulnerabilities
fastcgi_param HTTP_PROXY "";

#fastcgi_pass 127.0.0.1:9000;
fastcgi_pass unix:/run/php/php7.3-fpm.sock;
fastcgi_index index.php;

# include the fastcgi_param setting
include fastcgi_params;

# SCRIPT_FILENAME parameter is used for PHP FPM determining
#  the script name. If it is not set in fastcgi_params file,
# i.e. /etc/nginx/fastcgi_params or in the parent contexts,
# please comment off following line:
# fastcgi_param  SCRIPT_FILENAME   $document_root$fastcgi_script_name;

}

PHP application gets all other requests

location / {
#add_header X-Server $hostname;
try_files $uri @rewriteapp;
#more_clear_headers ‘X-Powered-By’ ‘X-Store’ ‘X-Locale’ ‘X-Env’ ‘Server’;

}

location @rewriteapp {
# rewrite all to app.php
rewrite ^(.*)$ /index.php last;
}

Hi!

Glad to see that you figured it out!
If you need more inspiration on how to tweak your systems, you might also have a look at the saltstack (and pillar) configurations in the devvm repository: https://github.com/spryker/devvm

Hi LazyStar,

Thank you very much. But I dont think thats a good idea to use vagrant or docker on a local linux machine for development of such a IO bound application. The productivity goes down and its very frustrating to get a very slow development process.

With a correct installation on bare metal developing is not “blazing fast” but with 4 seconds after cache clear its okay so far.

I prefer to spend some time figuring out how to correctly install all components via fast installing with docker but after that a very slow dev enviroment.

And just 1,5 Days to install and configure the techstack isnt that much time for this kind of Enterprice-Shopping Basket

:smiley:

Cheers

Hi Peter,

I wouldn’t agree as our spryker/docker-sdk solution (basically a wrapper around docker) delivers a very good development performance on Linux due to the fact that docker has a native support in Linux kernel and it doesn’t require such things as docker-sync alike Windows or MacOS.

Best,
Spryker Support Team

Hi Valeri,

I am totally on your site when I work on a fat desktop / laptop or a dedicated server(s) with good ram , ssd and cpu. then its no problem to spawn 10 containers with the docker repo and use php storm, android studio and slack beside.

Unfortunately I am limited to 16 GB RAM , Quadcore I7, SSD on Debian.

I benchmarked bare metal installation with recommended component-versions of the b2c version against the official docker image with docker version 19.03 .

Editing code with following cache clearing takes round about 4 seconds for reloading the page, which is still okay . On docker it takes 30-40 seconds to reload the entire page after editing some twig-templates with following cache clearing on Linux :slight_smile:

I know, that I can simply clear a smaller area of the cashfolder to prevent full cache rebuilds. It was just a rough test.

If I am back in office after corona :slight_smile: I can test on a 32 GB Mac with 8 i9 cores and SSD Disks.

If you are interressted I can post my results here.

KR

Peter