App Istall step 3 Error


#1

Hi,
on step 3 im gettin this error:

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
npm ERR! Linux 3.16.0-4-amd64
npm ERR! argv “/usr/bin/nodejs” “/usr/bin/npm” "install"
npm ERR! node v6.11.0
npm ERR! npm v3.10.10
npm ERR! path /data/shop/development/current/node_modules/.staging/js-yaml-99a27a29
npm ERR! code EPERM
npm ERR! errno -1
npm ERR! syscall rename

npm ERR! Error: EPERM: operation not permitted, rename ‘/data/shop/development/current/node_modules/.staging/js-yaml-99a27a29’ -> '/data/shop/development/current/node_modules/js-yaml’
npm ERR! at destStatted (/usr/lib/node_modules/npm/lib/install/action/finalize.js:25:7)
npm ERR! at /usr/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:264:29
npm ERR! at FSReqWrap.oncomplete (fs.js:123:15)
npm ERR!
npm ERR! Error: EPERM: operation not permitted, rename ‘/data/shop/development/current/node_modules/.staging/js-yaml-99a27a29’ -> '/data/shop/development/current/node_modules/js-yaml’
npm ERR! at Error (native)
npm ERR! { Error: EPERM: operation not permitted, rename ‘/data/shop/development/current/node_modules/.staging/js-yaml-99a27a29’ -> '/data/shop/development/current/node_modules/js-yaml’
npm ERR! at destStatted (/usr/lib/node_modules/npm/lib/install/action/finalize.js:25:7)
npm ERR! at /usr/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:264:29
npm ERR! at FSReqWrap.oncomplete (fs.js:123:15)
npm ERR!
npm ERR! Error: EPERM: operation not permitted, rename ‘/data/shop/development/current/node_modules/.staging/js-yaml-99a27a29’ -> '/data/shop/development/current/node_modules/js-yaml’
npm ERR! at Error (native) parent: ‘spryker-demoshop’ }
npm ERR!
npm ERR! Please try running this command again as root/Administrator.

npm ERR! Please include the following file with any support request:
npm ERR! /data/shop/development/current/npm-debug.log

Please help,
thx a lot!

Mikhail.


#2

Hi Mikhail,
thanks for your ticket.

I’m Alessandro, Frontend dev @ Spryker.

As I see, you’re trying to install Spryker on a linux machine. Are you on a VM or directly on your computer? If the former, which operating system do you have?
You’re getting an EPERM error: your permission setting is somehow wrong.
Check the user that runs npm and/or check the folder in which you’re installing the systems to see if you have the right privileges.

EDIT: sometimes, if you run this command on windows host, you might get problems with symlinks. In that case, there are different solutions you can apply. They’re related to npm strictly.

Let me know.
Cheers.